Archive

Posts Tagged ‘onboard administrator’

Managing an iLO from the OnBoard Administrator of an HP C-Class Enclosure

August 4, 2011 2 comments

I have been performing some work on an HP BladeSystem C7000 Enclosure this morning.

We have issues where the iLOs either have incorrect IP addresses or become unresponsive- issues caused by a bug in the old firmware releases.

What I needed to do was restart the iLO without impacting the blade, I could not simply log onto the iLO as it had an incorrect IP address. Beneath is an undocumented method to reset the iLO.

All command listed bellow must be issued from an SSH or telnet session to the active Onboard Administrator. I recommend PuTTY as the client; it is dead simple to use is surprisingly feature rich and best of all is free.

Reset a Nonresponsive or Inaccessible iLO

Replace ## with the blade slot of the blade that iLO resides on.

connect server ##
cd /map1
reset

The interface will become non-responsive for a while (less than one minute) while the interface to to the iLO times out.

 

Reset a Blade or Bay (Virtual Re-Seat)

This is a very useful command line that will reset the entire bay. It is equivalent to physically removing the blade from the enclosure (extremely useful if using back-to-back blades)

Reset bay ##

 

Rename the Server Name in the iLO:

This allows you to rename the server in the iLO (and therefore the name in the Onboard Administrator)

cd system1
set oemhp_server_name = TestValue
show oemhp_server_name
exit

Advertisements